티스토리 뷰



해당 오류는 Mysql-connector-java 가 5.1.22 버전보다 낮아서 생기는 문제입니다


만약 클러스터에서 해당 오류가 spark,hive등에서 발생하고 있다면, jdbc를 변경해주시면 됩니다 



https://community.hortonworks.com/articles/70912/hive-metastore-not-working-syntax-error-option-sql.html



저 같은경우는


1.jdbc를 받은다음


1.ambari-server resources 패치 

/var/lib/ambari-server/resource 내의 mysql-connector-java


그리고 각 클라이언트 또는 hive 가 깔린 /usr/hdp/버전/hive/lib 내의 mysql-connetor-java를 해당 버전으로 바꾼뒤 서비스를 다시 시작하였습니다





댓글
댓글쓰기 폼
Total
1,723,998
Today
265
Yesterday
320